1. Bienvenido Invitado! para poder interactuar con la comunidad y tener acceso a todas las características de la web.
  1. Bienvenido Invitado! para poder interactuar con la comunidad y tener acceso a todas las características de la web.

Problema con el StopSound

Tema en 'Problemas y Dudas' iniciado por Con Uve™, 28 Dic 2016.

    Con Uve™ Novato

    Mensajes:
    1
    Puntuación:
    +0 / 0 / -0
    Tengo un mapa con una logic_case y un logic_auto junto a unos cuantos ambient_generic para que al principio del mapa escoja aleatoriamente una canción y la reproduzca. Hasta aquí todo perfecto, ahora he creado un func_button que tendría que parar la canción que este sonando desde el principio del mapa y activar una en concreto, el problema viene cuando el boton activa perfectamente la canción pero no detiene la otra que está sonando.

    Aqui va como está el boton: https://gyazo.com/b4781d7730398de85c8e985f1c8db31c

    Que estoy haciendo mal?


    EDIT: Lo he "arreglado" probando mas cosas, con poner en vez de "stopsound" dejar "volume" y en parameter override dejar un "0" desaparece la canción, pero mi duda sigue, ¿como con el stopsound hago que se detenga?

    Enviolinador Miembro

    Mensajes:
    87
    Puntuación:
    +30 / 0 / -0
    Stopsound no ha funcionado bien nunca, por desgracia. La alternativa más normal, como ya has hecho, es utilizar 'Volume'. El motor está lleno de pequeños fallos similares, y en la mayoría de esos casos el problema no es lo que hagas tú sino la mala documentación.

Compartir esta página